1. We need your input for our next PR version. Discuss here!

Dismiss Notice

Don't forget to connect your Steam account to your forum profile. Click here to do this now or click your name in the right-top corner and choose 'External Accounts'.

Quest bug repository

Discussion in '[L4D2] Points Reloaded' started by Mute, Jul 28, 2016.

  1. Mute

    Mute Head Administrator Staff Member

    I plan on trying to fix as many bugs with quests as possible within my realm of ability, thing is I can't remember them all. Any and every quest related bug you remember, no matter how big or small, leave a post here and I'll try to sort them out.

    Current bugs I'm aware of:
    • Hunterized not counting super hunter kills
    • Resupplying does not display quest requirements
  2. Quote this came from: https://mgftw.com/forum/left-4-dead-...5915-quest-bug

    This was back when there was a number of quests that seemed to be bugged at the time (apparently this guy had a good solution to it). Now the thing is that the Artisan buff cannot be obtained without completing David's third quest. Since his quest his unavailable, the quest buff itself is impossible to get atm without doing events.

    Quote this came from: https://mgftw.com/forum/left-4-dead-...est-reward-bug

    Even though Xero's Mutation Shield Buff has expired about 13 days ago or so. This is still relevent, due to a bug with the wrong Mutation Shield Buff given. I assume that he was given the 1 month Mutation Shield Buff as a reward instead of the 1 day Mutation Shield Buff

    This is pretty much the same thing to do with David's third quest. Being Unable to access the last quest that Theodora is able to give to you, making the Piercing Bullets quest buff impossible to obtain.

    UPDATED: There are 2 more quests which are bugged.
    Steam chat with edward marlus about it is below.
    ♞♘[Σ]dward Marlus♞♘: Bryan quest is buggy
    ... (skipping part of chat to relevant things)
    timkit [â„¢Ûž]: bryan quest?
    ♞♘[Σ]dward Marlus♞♘ is now Online.
    ♞♘[Σ]dward Marlus♞♘: Yeah
    ♞♘[Σ]dward Marlus♞♘: The survival guide is bugged
    timkit [â„¢Ûž]: so in other words
    timkit [â„¢Ûž]: your unable to find it?
    ♞♘[Σ]dward Marlus♞♘: I have it on me
    ♞♘[Σ]dward Marlus♞♘: But the quest still refuses to complete itself
    timkit [â„¢Ûž]: you cant finish the quest?
    timkit [â„¢Ûž]: have you dumped the thing into a supply box then gone to complete the quest?
    timkit [â„¢Ûž]: or the supply box wont let you dump it in?
    ♞♘[Σ]dward Marlus♞♘: Supply box won't take it
    timkit [â„¢Ûž]: alright
    timkit [â„¢Ûž]: hmmm
    timkit [â„¢Ûž]: is it there in your quest inventory?
    ♞♘[Σ]dward Marlus♞♘: Yes
    ... (skipping part of chat to relevant things)
    ♞♘[Σ]dward Marlus♞♘: Also the one where you examine the pile of cows
    timkit [â„¢Ûž]: eh?
    ♞♘[Σ]dward Marlus♞♘: Cow piles don't light up anymore
    timkit [â„¢Ûž]: thats not a big deal
    timkit [â„¢Ûž]: just as long as you are able to press e and have it confirm
    timkit [â„¢Ûž]: as you did the thing
    timkit [â„¢Ûž]: then it should be all good
    ♞♘[Σ]dward Marlus♞♘: I cant
    ♞♘[Σ]dward Marlus♞♘: Lol
    timkit [â„¢Ûž]: you mean
    timkit [â„¢Ûž]: you cant press e on the cows?
    ♞♘[Σ]dward Marlus♞♘: Yup I cannot press enter on the cows
    timkit [â„¢Ûž]: the e key
    timkit [â„¢Ûž]: not the enter key
    ♞♘[Σ]dward Marlus♞♘: Use key yes
    timkit [â„¢Ûž]: ah ok

    Edward Marlus does have his use key set to e and it wont let him hold down the button to examine the cows for one of Kyle's quests. I can confirm from what edward marlus says that Bryan's Survival Guide Quest is bugged.

    OK.... so to summarize.

    The quest bugs currently still around:
    - Theodora and David's quests not being able to be completed
    - The reward for 1 Day Mutation Shield Buff being wrongly given as a 30 Day (1 Month) Mutation Shield Buff
    - Bryan's Survival Guide quest, cannot put the item into the supply box
    - Kyle's quest, unable to examine the cow as a requirement for one of his quests.

    That's all i've been aware of to do with the quest bugs over the past several weeks. If I know of anyone that knows any more quest bugs. I'll be updating.
  3. Mute

    Mute Head Administrator Staff Member

    David's and Theodora's quests appear to be fine, one thing I've noted is Inseparable 1 doesn't display the requirements (working on it), and that, for some reason, Inseparable 3 is unlocked if Inseparable 1 is completed, not 2. This may have been a cause of issue for the aforementioned party, and has such been fixed to unlock after Inseparable 2.

    In the case of the Survival Guide, has he tried to remove the item from his quest inventory and finding it again? If not, tell him to try that.

    For the cow, I found the selecting of the cow to be a bit dodgy. Tell him to try to stand on the cow and hold the use key as opposed to next to it. I can use it even if I don't have the quest unlocked. Also take into consideration that they can only be examined once, so if someone else uses it, no one else can.

    The mutation shield duration is correct, it is just the message displayed that is incorrect, as has been fixed.
  4. I see about the problem that theodora's quest did have. well, ill let fuzzy llama know that he should be able to do inseparable 3 with no problems now. I have also noticed that I am able to inflate the tire (use it) even if I have already completed the quest or have not taken it atm as an active mission. That there is pretty much the same thing as you say for the cow piles so I just wanted to let you know about that. Fair enough about the message displayed to do with the mutation shield buff reward that was fixed now. players should now know what duration of mutation shield buff their getting as a reward

    edward marlus will attempt to get the cow quest done. He is ALL GOOD with the bryan's survival quest as I got told he was able to get it done.

    Thanks for fixing the quest bugs so far mute! glad we can have another coder around on mgftw :D
  5. XeroX

    XeroX Junior Member

    On the tranquility lane broken (or very simliar) quest where you have to kill the infected on Crash Course and inflate the tire it doesnt save the inflated tire state if you don't do the infected and then hand the quest in.
  6. ale758

    ale758 Junior Member

    Minor bug. In Thief's Whims item checking is swapped. When you pick up soldier's uniform it checks bag of fake gems and viceversa. Apart from this, quest works and you can complete it.
  7. Mute

    Mute Head Administrator Staff Member

    About the tire, I can recreate it, but I'm not entirely sure how to go about fixing it. I'll give it more of a look and if I can't manage, I'll let HC know. At least the two objectives are right next to each other.

    The bug with Thief's Whims has been fixed.
  8. ale758

    ale758 Junior Member

    Will. Join forces 1. One of the request is to complete 15 finales with every survivors alive. The first time I tried it I reached 3/15 then the counter seemed to be stucked. I also made some tests by completing finales with only bots or with mixed bots/players teams. I also checked that no players joined the finales due to the fact that it seems that they are moved to "dead" players as you can notice in the end credits. I restarted it but now the counter is stuck at 0/15 even after completing it again with the methods above.
  9. Mute

    Mute Head Administrator Staff Member

    The description for that quest is a bit off. It's not actually 'all survivors', it only counts if 16 (or higher) players make it out alive, so it's really only all survivors on a full server.
  10. XeroX

    XeroX Junior Member

    Could there maybe add a specific check for the sacrifice campaign so it only checks for 15 ppl ? As you are forced to kill one survivor which makes it impossible to achieve the strike.
  11. Mute

    Mute Head Administrator Staff Member

    The player who restarts the generator isn't killed, I have many times seen strikes achieved on The Sacrifice.
  12. Kaji

    Kaji Junior Member

    I don't know what i'm doing wrong because I still can't get Inseparable 3 quest to activate. I completed the 1st quest long ago, I can't remember date, and the 2nd one was completed a few days just before I made that post.
    I'm not sure why but I still get the same grayed out option for "Accept Deal"
    Inseparable 3
  13. Mute

    Mute Head Administrator Staff Member

    That is odd. Could I get your Steam ID? It may be that something has gone wrong in the database and as a result the quest isn't unlocking for you.

    On a similar note, if you have done Inseparable 3 in the past and lost the quest buff Piercing Bullets when it was removed, HC has made it such that you can now do the quest again to get the buff back.
  14. ale758

    ale758 Junior Member

    Regarding of Will's join forces 1 is it possible to change the requirements? I mean these days ( but i must say the last weeks) is very rare to have as many as 16 people in the server, so my request is to reduce the number of finales to complete (lets say 8 from 15) or the minimum of survivals alive (lets say 10). Thanks
  15. XeroX

    XeroX Junior Member

    I guess thats because ppl are vacation so give it some time when everyone returns and the player count will rais up again.
  16. If anyone was playing Custom COOP back last year or so, you would all remember about the health dispenser crash bug. Unfortunately the bad news is that it's still alive. just wanted to mention that.

    Also confirmed by ∉ddie【ℓ ღℓ i】via steam chat

    ∉ddie【ℓ ღℓ i】: still waiting for another fix tho
    ∉ddie【ℓ ღℓ i】: your game will crash when using health dispenser
    ∉ddie【ℓ ღℓ i】: in some maps it does lol
    timkit [â„¢Ûž]: assuming its Custom COOP, ill mention it
    ∉ddie【ℓ ღℓ i】: hope theres a fix for it
    ∉ddie【ℓ ღℓ i】: oh ok ty :P
    ∉ddie【ℓ ღℓ i】: last night i used health dispenser and ended up crashing some people's game lol
    ∉ddie【ℓ ღℓ i】: including mine
    timkit [â„¢Ûž]: I see
    timkit [â„¢Ûž]: :P
    ∉ddie【ℓ ღℓ i】: oh and raz's too :P
    ∉ddie【ℓ ღℓ i】: hahaa
  17. fnord

    fnord Game Server Moderator Staff Member

    Ya I think it happens on Military Industrial Complex II finale
  18. The Looking for Power 1 is bugged, as confirmed by multiple people on COOP today.
    The thing about it is that if you were to kill a tier 1 or a tier 2 tank the quest would not update from 0/1 to 1/1 to indicate that you completed the action.

    Here is the steam chat between me and gonzalo to confirm the bug.
    timkit [â„¢Ûž]: just to make absolutely clear about the bug
    timkit [â„¢Ûž]: you cant get a 1/1 from killing tier 1 and tier 2 tanks?
    Gonzalo [Σ]: yeah
    timkit [â„¢Ûž]: ok
  19. Mute

    Mute Head Administrator Staff Member

    I just tried it out, and the quest appears to work fine for me. Ask him to reset the quest and try again, and see if it still doesn't count it.

Share This Page