1. 20 New buffs are now available in MG Store!

  2. We need your input for our next PR version. Discuss here!

Dismiss Notice

Don't forget to connect your Steam account to your forum profile. Click here to do this now or click your name in the right-top corner and choose 'External Accounts'.

Glitched Quests

Discussion in 'Server Questions / Issues' started by Jang23, Oct 2, 2016.

  1. Jang23

    Jang23 Junior Member

    I've had this problem for a while now and it's really annoying. All my quests cannot be completed. I either can't turn in completed quests, like the one that requires 8 mutated blood cells, or it won't let me complete tasks like picking up items. Every quest item is glowing green, but I can't pick them up. I've tried turning in the quests multiple times, tried the check option for the quests and I've tried declining them to see if that would work, but they didn't. I've missed out on one Bloody Tank, 5 Shaman Tanks and one Fighter Tank's quests because of this bug. Please help. |:(
     
  2. Mute

    Mute Head Administrator Staff Member

    Can you tell me specifically which quests they are, its a little hard to debug without knowing what they are. Also, have you tried completely cancelling the quest (Select View Rewards in the quest, then Cancel Quest) and re-accepting them? If you took the quest a long time ago and are trying to complete it now, the quest may not update correctly until you restart the quest from scratch.

    Also every quest item will glow green whether you can or can't pick them up, it's like that so you can see tell other players who may have missed an item they need.
     
  3. Jang23

    Jang23 Junior Member

    Thanks, I didn't realize that was an option. And I was told that only mission items you need will glow, so I thought that was also a glitch.
     
  4. Jang23

    Jang23 Junior Member

    It's been working so far except for one mission. The mission by Thief that requires a golden necklace. It shows that I have it in my inv, but when I try to turn it into the box, it says that there is nothing to put in.
     
  5. Mute

    Mute Head Administrator Staff Member

    Chances are you might have to throw away the Golden Necklace in your quest inventory (Select the item in Quest Inventory and there should be some option to remove it) and try to find it again if it isn't letting you put the item in the box. What does the quest requirement say? Is it Pending or just 0/1?
     
  6. Jang23

    Jang23 Junior Member

    After I denied and re-accepted the mission, I was able to check it and complete the mission.
     

Share This Page