1. Sickening Tank Scenario returns! More info here.

Cannot Type in Coop Chat

Discussion in 'Server Questions / Issues' started by Ivan, Oct 4, 2018.

  1. Ivan

    Ivan New Member

    Have had this problem for a while now. When I join any coop server, i would be able to type for a few second(5-10s depends on the ping) then I won't be able to type anymore. I can still open chat, but when I send the word it just doesn't show up in the server. I cannot use any command( !cp !buy etc.). However, I am able to chat like normal in Versus and Scenario server. Not sure what is causing this server side, my side, or am I banned from chat(lol?).

    Things I have tried:
    1. Unbind key/set default key
    2. Verifying Integrity of Game Files
    3. Deleting config.cfg
    4. Reinstalling the game
    All of these didn't helped me fix the problem.

    If anyone have any ideas on how to fix this problem please tell, I would like to become active again. :)
     
  2. Mute

    Mute Head Administrator Staff Member

    When was the last time you connected and had the issue, and on which server? I don't really have a solution but at the very least I can check if the server receives your 'say' commands.

    Ideally you could also provide a reference point (other people's chat messages for example) so I can quickly find it in the logs.
     
  3. Ivan

    Ivan New Member

    Server Time 10/05/2018 - 09:59:01
    Coop Asia 1
    You can see that I was able to type thetime, test 1, and test 2
    But when I try to type test 3 it didn't show up
     

    Attached Files:

  4. Mute

    Mute Head Administrator Staff Member

    I took a look at the server logs and it seems your third test message outright didn't reach the server. Can you try to perform a global or clan chat message after your regular messages stop working, and see if they work? Also, try to enter any command through console, not chat, e.g. sm_buy or sm_buffs and tell me if they show up.

    I'm honestly not sure what the issue here is, and search results give nothing, so I have to see what does and doesn't work.
     
  5. Ivan

    Ivan New Member

    Clan chat and global chat doesn't seem to work either. sm_buy and sm_buff does nothing when I tried to use them(not sure if I used it correctly, but should be)

    The "FCVAR_SERVER_CAN_EXECUTE: Bind" has been showing up every time I join the server after I'm having this problem.
    Not sure if it has anything to do with the problem since it also pop up in VS and Scenario server, but I am able to chat like normal in those server. But just wanted to point it out if it helps.
     

    Attached Files:

  6. Mute

    Mute Head Administrator Staff Member

    Hmm, once again chat not being registered server side, I did see both sm_cp and sm_buy, but neither clan chat nor global chat. The bind thing isn't relevant, happens to everyone. Have you tried connecting after removing/disabling all of your addons? The fact that it's only not working on COOP is rather confusing.
     
  7. Ivan

    Ivan New Member

    After disabling addons I still couldn't chat. But the game was all messed up because some of my addon changes placement of UI. So I decide to check integrity of game files again. Then, I went to EU to test if I was able to chat, and the chat work perfectly fine. However, when I join Asia 2, I wasn't able to chat again. Went back to EU again to test and it still work fine. Now I am even more confused lol.
     
  8. Mute

    Mute Head Administrator Staff Member

    Ok so I'm completely out of ideas here, I've asked some other root admins if they know anything about it since they know more about what I assume this to be, a network issue. Considering both EU and Asia have the same plugin configurations I don't think the issue lies there. When your commands fail to work, can you still play the game normally otherwise with no latency/pack loss issues, or anything worse than usual? Also, can you try sm_saveme command when other things stop working and take a screenshot, that way I can instantly see if you get a response or not (since the command should always fire back a message)
     
  9. Ivan

    Ivan New Member

    Both !saveme and sm_saveme doesn't seem to work, at least I didn't see any PR notification.

    For issues, I found that when I try to send/take stuff for the quest supply box. It didn't send the usual "There is nothing in the box......" PR message. Aside from that, there is no other issues regarding gameplay or latency loss after the chat command fail. I was able to interact with craft items and quest item normally and it is still sending PR for everything(Rep, Bounty, etc.).
     

    Attached Files:

  10. BadBreezy™

    BadBreezy™ New Member

    I had this same issue recently, figured it was my lousy ping.
     
  11. Ivan

    Ivan New Member

    Definitely not because of my ping, since I had better connection in asia.(I'm from Thailand)
    The problem however did resolve by itself. And now I'm able to type normally.
    However, I still have no idea what cause it.
     
    BadBreezy™ likes this.
  12. BadBreezy™

    BadBreezy™ New Member

    That rules out my ping theory... Also, haven't had that issue since, maybe it fixed itself like things sometimes do... -fingers crossed-
     

Share This Page